What’s Vulnerable › Vulnerabilities
CVE-2024-5472: WP QuickLaTeX < 3.8.7 - Admin+ Stored XSS in Background Color field
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP QuickLaTeX WordPress plugin before 3.8.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- WP QuickLaTeX: before 3.8.7 — fixed in 3.8.7
How to fix
Upgrade to a fixed version: WP QuickLaTeX 3.8.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dcddc2de-c32c-4f8c-8490-f3d980b05822/
- https://wpscan.com/vulnerability/dcddc2de-c32c-4f8c-8490-f3d980b05822/
Get alerted when CVE-2024-5472 or the next vulnerability affects your stack