What’s Vulnerable › Vulnerabilities
CVE-2024-5475: Responsive video embed < 0.5.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive video embed WordPress plugin before 0.5.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Responsive video embed: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: Responsive video embed 0.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cee66543-b5d6-4205-8f9b-0febd7fee445/
- https://wpscan.com/vulnerability/cee66543-b5d6-4205-8f9b-0febd7fee445/
Get alerted when CVE-2024-5475 or the next vulnerability affects your stack