What’s Vulnerable › Vulnerabilities
CVE-2024-54779
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds is vulnerable to Cross Site Scripting (XSS) in widgets/log.widget.php.
Affected products
- Netgate Pfsense Ce: before 2.8.0 — fixed in 2.8.0
- Netgate Pfsense Plus: before 25.03 — fixed in 25.03
How to fix
Upgrade to a fixed version: Netgate Pfsense Ce 2.8.0; Netgate Pfsense Plus 25.03. Check the vendor advisory for mitigations.
References
- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/
- https://docs.netgate.com/downloads/pfSense-SA-25_01.webgui.asc
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2
Get alerted when CVE-2024-54779 or the next vulnerability affects your stack