What’s Vulnerable › Vulnerabilities
CVE-2024-54780
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-94
Description
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds are vulnerable to command injection in the OpenVPN widget due to improper sanitization of user-supplied input to the OpenVPN management interface. An authenticated attacker can exploit this vulnerability by injecting arbitrary OpenVPN management commands via the remipp parameter.
Affected products
- Netgate Pfsense Ce: before 2.8.0 — fixed in 2.8.0
- Netgate Pfsense Plus: before 25.03 — fixed in 25.03
How to fix
Upgrade to a fixed version: Netgate Pfsense Ce 2.8.0; Netgate Pfsense Plus 25.03. Check the vendor advisory for mitigations.
References
- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2
Get alerted when CVE-2024-54780 or the next vulnerability affects your stack