What’s Vulnerable › Vulnerabilities
CVE-2024-5505: NETGEAR ProSAFE Network Management System UpLoadServlet Directory Traversal Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-22
Description
NETGEAR ProSAFE Network Management System UpLoadServlet Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of NETGEAR ProSAFE Network Management System. Authentication is required to exploit this vulnerability. The specific flaw exists within the UpLoadServlet class. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-22724.
Affected products
- NETGEAR ProSAFE Network Management System: before 1.7.0.37 — fixed in 1.7.0.37
How to fix
Upgrade to a fixed version: NETGEAR ProSAFE Network Management System 1.7.0.37. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-24-563/
- https://www.zerodayinitiative.com/advisories/ZDI-24-563/
Get alerted when CVE-2024-5505 or the next vulnerability affects your stack