What’s Vulnerable › Vulnerabilities
CVE-2024-5522: HTML5 Video Player < 2.5.27 - Unauthenticated SQLi
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The HTML5 Video Player WordPress plugin before 2.5.27 does not sanitize and escape a parameter from a REST route before using it in a SQL statement, allowing unauthenticated users to perform SQL injection attacks
Affected products
- bplugins HTML5 Video Player – Embed and Play Videos in Custom Player: before 2.5.27 — fixed in 2.5.27
How to fix
Upgrade to a fixed version: bplugins HTML5 Video Player – Embed and Play Videos in Custom Player 2.5.27. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bc76ef95-a2a9-4185-8ed9-1059097a506a/
- https://wpscan.com/vulnerability/bc76ef95-a2a9-4185-8ed9-1059097a506a/
Get alerted when CVE-2024-5522 or the next vulnerability affects your stack