What’s Vulnerable › Vulnerabilities
CVE-2024-55225
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-276
Description
An issue in the component src/api/identity.rs of Vaultwarden prior to v1.32.5 allows attackers to impersonate users, including Administrators, via a crafted authorization request.
Affected products
- dani-garcia vaultwarden: before 1.32.5 — fixed in 1.32.5
How to fix
Upgrade to a fixed version: dani-garcia vaultwarden 1.32.5. Check the vendor advisory for mitigations.
References
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.32.4
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.32.5
- https://insinuator.net/2024/11/vulnerability-disclosure-authentication-bypass-in-vaultwarden-versions-1-32-5/
Get alerted when CVE-2024-55225 or the next vulnerability affects your stack