What’s Vulnerable › Vulnerabilities
CVE-2024-5529: WP QuickLaTeX < 3.8.8 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP QuickLaTeX WordPress plugin before 3.8.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- WP QuickLaTeX: before 3.8.8 — fixed in 3.8.8
How to fix
Upgrade to a fixed version: WP QuickLaTeX 3.8.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/66d0b4b7-cd4b-4ec4-95c0-d50773cb0b8f/
- https://wpscan.com/vulnerability/66d0b4b7-cd4b-4ec4-95c0-d50773cb0b8f/
Get alerted when CVE-2024-5529 or the next vulnerability affects your stack