What’s Vulnerable › Vulnerabilities
CVE-2024-5533: Divi <= 4.25.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-20
Description
The Divi theme for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 4.25.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Elegant Themes Divi: before 4.25.2 — fixed in 4.25.2
How to fix
Upgrade to a fixed version: Elegant Themes Divi 4.25.2. Check the vendor advisory for mitigations.
References
- https://www.elegantthemes.com/api/changelog/divi.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6571a899-f217-434f-bbed-b1faf77a8d8b?source=cve
- https://www.elegantthemes.com/api/changelog/divi.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6571a899-f217-434f-bbed-b1faf77a8d8b?source=cve
Get alerted when CVE-2024-5533 or the next vulnerability affects your stack