What’s Vulnerable › Vulnerabilities
CVE-2024-5540: ALC WebCTRL Carrier i-Vu Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-27 · updated 2026-10-27
- Weakness: CWE-79
Description
The reflective cross-site scripting vulnerability found in ALC WebCTRL and Carrier i-Vu in versions older than 8.0 affects login panels allowing a malicious actor to compromise the client browser .
Affected products
- Automated Logic WebCtrl: before 8.0 — fixed in 8.0
- Carrier i-Vu: before 8.0 — fixed in 8.0
How to fix
Upgrade to a fixed version: Automated Logic WebCtrl 8.0; Carrier i-Vu 8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5540 or the next vulnerability affects your stack