What’s Vulnerable › Vulnerabilities
CVE-2024-55549
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-416
Description
xsltGetInheritedNsList in libxslt before 1.1.43 has a use-after-free issue related to exclusion of result prefixes.
Affected products
- xmlsoft libxslt: before 1.1.43 — fixed in 1.1.43
How to fix
Upgrade to a fixed version: xmlsoft libxslt 1.1.43. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libxslt/-/issues/127
- https://lists.debian.org/debian-lts-announce/2025/03/msg00015.html
Get alerted when CVE-2024-55549 or the next vulnerability affects your stack