What’s Vulnerable › Vulnerabilities
CVE-2024-5555: Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) <= 5.6.5 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘social-link-title’ parameter in all versions up to, and including, 5.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- bdthemes Element Pack – Widgets, Templates & Addons for Elementor: before 5.6.6 — fixed in 5.6.6
How to fix
Upgrade to a fixed version: bdthemes Element Pack – Widgets, Templates & Addons for Elementor 5.6.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bdthemes-element-pack-lite/trunk/modules/member/widgets/member.php#L1273
- https://plugins.trac.wordpress.org/changeset/3096559/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cdb69e0e-f3d4-4b5b-9bdf-14018f4c7ecc?source=cve
- https://plugins.trac.wordpress.org/browser/bdthemes-element-pack-lite/trunk/modules/member/widgets/member.php#L1273
- https://plugins.trac.wordpress.org/changeset/3096559/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cdb69e0e-f3d4-4b5b-9bdf-14018f4c7ecc?source=cve
Get alerted when CVE-2024-5555 or the next vulnerability affects your stack