What’s Vulnerable › Vulnerabilities
CVE-2024-55591: Fortinet FortiOS and FortiProxy Authentication Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-01-14
- EPSS: 94.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-14 · updated 2026-08-05
- Weakness: CWE-288
Description
An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS version 7.0.0 through 7.0.16 and FortiProxy version 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12 allows a remote attacker to gain super-admin privileges via crafted requests to Node.js websocket module.
Affected products
- Fortinet FortiOS (FortiGate): from 7.0.0 before 7.0.17 — fixed in 7.0.17
- Fortinet FortiProxy: from 7.0.0 before 7.0.20; from 7.2.0 before 7.2.13 — fixed in 7.0.20, 7.2.13
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.17; Fortinet FortiProxy 7.0.20, 7.2.13. Check the vendor advisory for mitigations.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-24-535
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-55591
Get alerted when CVE-2024-55591 or the next vulnerability affects your stack