What’s Vulnerable › Vulnerabilities
CVE-2024-55633: Apache Superset: SQLLab Improper readonly query validation allows unauthorized write access
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
Affected products
- Apache Superset: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Superset 4.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/bwmd17fcvljt9q4cgctp4v09zh3qs7fb
- http://www.openwall.com/lists/oss-security/2024/12/12/1
Get alerted when CVE-2024-55633 or the next vulnerability affects your stack