What’s Vulnerable › Vulnerabilities
CVE-2024-55635: Drupal core - Critical - Cross Site Scripting - SA-CORE-2024-005
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Drupal Core allows Cross-Site Scripting (XSS).This issue affects Drupal Core: from 7.0 before 7.102.
Affected products
- Drupal: from 7.0 before 7.102 — fixed in 7.102
How to fix
Upgrade to a fixed version: Drupal 7.102. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-55635 or the next vulnerability affects your stack