What’s Vulnerable › Vulnerabilities
CVE-2024-55636: Drupal core - Less critical - Gadget chain - SA-CORE-2024-006
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-915
Description
Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so called gadget chain presents no direct threat, but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.
Affected products
- Drupal: from 8.0.0 before 10.2.11; from 10.3.0 before 10.3.9; from 11.0.0 before 11.0.8 — fixed in 10.2.11, 10.3.9, 11.0.8
How to fix
Upgrade to a fixed version: Drupal 10.2.11, 10.3.9, 11.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-55636 or the next vulnerability affects your stack