What’s Vulnerable › Vulnerabilities
CVE-2024-55638: Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-915
Description
Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.
Affected products
- Drupal: from 7.0 before 7.102; from 8.0.0 before 10.2.11; from 10.3.0 before 10.3.9 — fixed in 10.2.11, 10.3.9, 7.102
How to fix
Upgrade to a fixed version: Drupal 10.2.11, 10.3.9, 7.102. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-55638 or the next vulnerability affects your stack