What’s Vulnerable › Vulnerabilities

CVE-2024-5566: Improper Privilege Management allows for access to unauthorized repository content during migration

Description

An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.14, 3.11.12, 3.12.6, 3.9.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5566 or the next vulnerability affects your stack