What’s Vulnerable › Vulnerabilities
CVE-2024-55661: Laravel Pulse Allows Remote Code Execution via Unprotected Query Method
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-94
Description
Laravel Pulse is a real-time application performance monitoring tool and dashboard for Laravel applications. A vulnerability has been discovered in Laravel Pulse prior to version 1.3.1 that could allow remote code execution through the public `remember()` method in the `Laravel\Pulse\Livewire\Concerns\RemembersQueries` trait. This method is accessible via Livewire components and can be exploited to call arbitrary callables within the application. An authenticated user with access to Laravel Pulse dashboard can execute arbitrary code by calling any function or static method in which the callable is a function or static method and the callable has no parameters or no strict parameter types. The vulnerable to component is `remember(callable $query, string $key = '')` method in `Laravel\Pulse\Livewire\Concerns\RemembersQueries`, and the vulnerability affects all Pulse card components that use this trait. Version 1.3.1 contains a patch.
Affected products
- laravel pulse: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: laravel pulse 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/laravel/pulse/commit/d1a5bf2eca36c6e3bedb4ceecd45df7d002a1ebc
- https://github.com/laravel/pulse/security/advisories/GHSA-8vwh-pr89-4mw2
Get alerted when CVE-2024-55661 or the next vulnerability affects your stack