What’s Vulnerable › Vulnerabilities
CVE-2024-5575: Ditty < 3.1.43 - Author+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.43 does not sanitise and escape some of its blocks' settings, which could allow high privilege users such as authors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Ditty: before 3.1.43 — fixed in 3.1.43
How to fix
Upgrade to a fixed version: Ditty 3.1.43. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/65d1abb7-92e9-4cc4-a1d0-84985b484af3/
- https://wpscan.com/vulnerability/65d1abb7-92e9-4cc4-a1d0-84985b484af3/
Get alerted when CVE-2024-5575 or the next vulnerability affects your stack