What’s Vulnerable › Vulnerabilities
CVE-2024-5576: Tutor LMS Elementor Addons <= 2.1.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Course Carousel Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tutor LMS Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'course_carousel_skin' attribute within the plugin's Course Carousel widget in all versions up to, and including, 2.1.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themeum Tutor LMS Elementor Addons: before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: themeum Tutor LMS Elementor Addons 2.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tutor-lms-elementor-addons/tags/2.1.4/templates/course/course-carousel.php#L81
- https://plugins.trac.wordpress.org/changeset/3136459/
- https://plugins.trac.wordpress.org/changeset/3136459/#file13
- https://plugins.trac.wordpress.org/changeset/3136459/#file9
- https://wordpress.org/plugins/tutor-lms-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7fdd1b1c-84b5-451a-a921-80be3b154398?source=cve
Get alerted when CVE-2024-5576 or the next vulnerability affects your stack