What’s Vulnerable › Vulnerabilities
CVE-2024-5582: Schema & Structured Data for WP & AMP <= 1.33 - Authenticated (Contributor+) Stored Cross-Site Scripting via url Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Schema & Structured Data for WP & AMP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'url' attribute within the Q&A Block widget in all versions up to, and including, 1.33 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- magazine3 Schema & Structured Data for WP & AMP: before 1.34.1 — fixed in 1.34.1
How to fix
Upgrade to a fixed version: magazine3 Schema & Structured Data for WP & AMP 1.34.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/schema-and-structured-data-for-wp/tags/1.31/modules/elementor/widgets/qanda-block.php#L355
- https://plugins.trac.wordpress.org/browser/schema-and-structured-data-for-wp/trunk/modules/elementor/widgets/class-qanda-block.php#L369
- https://wordpress.org/plugins/schema-and-structured-data-for-wp/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ab650b99-ab15-4ddc-a622-cb43ab554ba7?source=cve
- https://plugins.trac.wordpress.org/browser/schema-and-structured-data-for-wp/tags/1.31/modules/elementor/widgets/qanda-block.php#L355
- https://plugins.trac.wordpress.org/browser/schema-and-structured-data-for-wp/trunk/modules/elementor/widgets/class-qanda-block.php#L369
- https://wordpress.org/plugins/schema-and-structured-data-for-wp/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ab650b99-ab15-4ddc-a622-cb43ab554ba7?source=cve
Get alerted when CVE-2024-5582 or the next vulnerability affects your stack