What’s Vulnerable › Vulnerabilities
CVE-2024-55879: XWiki allows RCE from script right in configurable sections
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-862
Description
XWiki Platform is a generic wiki platform. Starting in version 2.3 and prior to versions 15.10.9, 16.3.0, any user with script rights can perform arbitrary remote code execution by adding instances of `XWiki.ConfigurableClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.9 and 16.3.0. No known workarounds are available except upgrading.
Affected products
- xwiki-platform: from 2.3 before 15.10.9; from 16.0.0 before 16.3.0 — fixed in 15.10.9, 16.3.0
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.9, 16.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/8493435ff9606905a2d913607d6c79862d0c168d
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-r279-47wg-chpr
- https://jira.xwiki.org/browse/XWIKI-21207
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-wh34-m772-5398
Get alerted when CVE-2024-55879 or the next vulnerability affects your stack