What’s Vulnerable › Vulnerabilities
CVE-2024-55889: phpMyFAQ Vulnerable to Unintended File Download Triggered by Embedded Frames
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-451
Description
phpMyFAQ is an open source FAQ web application. Prior to version 3.2.10, a vulnerability exists in the FAQ Record component where a privileged attacker can trigger a file download on a victim's machine upon page visit by embedding it in an <iframe> element without user interaction or explicit consent. Version 3.2.10 fixes the issue.
Affected products
- thorsten phpMyFAQ: before 3.2.10 — fixed in 3.2.10
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 3.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/commit/fa0f7368dc3288eedb1915def64ef8fb270f711d
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-m3r7-8gw7-qwvc
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-m3r7-8gw7-qwvc
Get alerted when CVE-2024-55889 or the next vulnerability affects your stack