What’s Vulnerable › Vulnerabilities
CVE-2024-55890: D-Tale allows Remote Code Execution through the Custom Filter Input
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
D-Tale is a visualizer for pandas data structures. Prior to version 3.16.1, users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.16.1 where the `update-settings` endpoint blocks the ability for users to update the `enable_custom_filters` flag. The only workaround for versions earlier than 3.16.1 is to only host D-Tale to trusted users.
Affected products
- man-group dtale: before 3.16.1
References
- https://github.com/man-group/dtale#custom-filter
- https://github.com/man-group/dtale/commit/1e26ed3ca12fe83812b90f12a2b3e5fb0b740f7a
- https://github.com/man-group/dtale/security/advisories/GHSA-832w-fhmw-w4f4
Get alerted when CVE-2024-55890 or the next vulnerability affects your stack