What’s Vulnerable › Vulnerabilities

CVE-2024-55904: IBM DevOps Deploy / IBM UrbanCode Deploy command injection

Description

IBM DevOps Deploy 8.0 through 8.0.1.4, 8.1 through 8.1.0.0 / IBM UrbanCode Deploy 7.0 through 7.0.5.25, 7.1 through 7.1.2.21, 7.2 through 7.2.3.14, and 7.3 through 7.3.2.9 could allow a remote privileged authenticated attacker to execute arbitrary commands on the system by sending specially crafted input containing special elements.

Affected products

How to fix

Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.5; IBM UrbanCode Deploy 7.0.5.26, 7.1.2.22, 7.2.3.15, 7.3.2.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-55904 or the next vulnerability affects your stack