What’s Vulnerable › Vulnerabilities
CVE-2024-5594
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-1287
Description
OpenVPN before 2.6.11 does not santize PUSH_REPLY messages properly which an attacker controlling the server can use to inject unexpected arbitrary data ending up in client logs.
Affected products
- OpenVPN: from 2.6.0 before 2.6.11 — fixed in 2.6.11
How to fix
Upgrade to a fixed version: OpenVPN 2.6.11. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2024-5594
- https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07634.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00005.html
Get alerted when CVE-2024-5594 or the next vulnerability affects your stack