What’s Vulnerable › Vulnerabilities
CVE-2024-55950: Tabby has a TCC Bypass via Unnecessary Permissive Entitlements in Tabby
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-26 · updated 2026-06-17
- Weakness: CWE-276
Description
Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.216, Tabby terminal emulator contains overly permissive entitlements that are unnecessary for its core functionality and plugin system, creating potential security vulnerabilities. The application currently holds powerful permissions including camera, microphone access, and the ability to access personal folders (Downloads, Documents, etc.) through Apple Events, while also maintaining dangerous entitlements that enable code injection. The concerning entitlements are com.apple.security.cs.allow-dyld-environment-variables and com.apple.security.cs.disable-library-validation. Since Tabby's plugins and themes are NodeJS-based without native libraries or frameworks, and no environment variables are used in the codebase, it is recommended to review and remove at least one of the entitlements (com.apple.security.cs.disable-library-validation or com.apple.security.cs.allow-dyld-environment-variables) to prevent DYLD_INSERT_LIBRARIES injection while maintaining full application functionality. This vulnerability is fixed in 1.0.216.
Affected products
- Eugeny tabby: before 1.0.216
References
- https://github.com/Eugeny/tabby/commit/e1e6e1cdab0310a881e36afd7c2744e5f905518b
- https://github.com/Eugeny/tabby/security/advisories/GHSA-jx33-9jc7-24gc
- https://github.com/Eugeny/tabby/security/advisories/GHSA-jx33-9jc7-24gc
Get alerted when CVE-2024-55950 or the next vulnerability affects your stack