What’s Vulnerable › Vulnerabilities
CVE-2024-55963
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue was discovered in Appsmith before 1.51. A user on Appsmith that doesn't have admin permissions can trigger the restart API on Appsmith, causing a server restart. This is still within the Appsmith container, and the impact is limited to Appsmith's own server only, but there is a denial of service because it can be continually restarted. This is due to incorrect access control checks, which should check for super user permissions on the incoming request.
Affected products
- appsmithorg appsmith: before 1.51 — fixed in 1.51
How to fix
Upgrade to a fixed version: appsmithorg appsmith 1.51. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-55963 or the next vulnerability affects your stack