What’s Vulnerable › Vulnerabilities
CVE-2024-55964
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in Appsmith before 1.52. An incorrectly configured PostgreSQL instance in the Appsmith image leads to remote command execution inside the Appsmith Docker container. The attacker must be able to access Appsmith, login to it, create a datasource, create a query against that datasource, and execute that query.
Affected products
- appsmithorg appsmith: before 1.52 — fixed in 1.52
How to fix
Upgrade to a fixed version: appsmithorg appsmith 1.52. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-55964 or the next vulnerability affects your stack