What’s Vulnerable › Vulnerabilities
CVE-2024-5598: Advanced File Manager <= 5.2.4 - Sensitive Information Exposure via Directory Listing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-29 · updated 2026-06-17
- Weakness: CWE-922
Description
The Advanced File Manager plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.2.4 via the 'fma_local_file_system' function. This makes it possible for unauthenticated attackers to extract sensitive data including backups or other sensitive information if the files have been moved to the built-in Trash folder.
Affected products
- saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution: before 5.2.5 — fixed in 5.2.5
How to fix
Upgrade to a fixed version: saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution 5.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_connector.php#L13
- https://plugins.trac.wordpress.org/changeset/3107587/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9d4ff5ed-8857-46b8-942b-ac0f47880a95?source=cve
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_connector.php#L13
- https://plugins.trac.wordpress.org/changeset/3107587/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9d4ff5ed-8857-46b8-942b-ac0f47880a95?source=cve
Get alerted when CVE-2024-5598 or the next vulnerability affects your stack