What’s Vulnerable › Vulnerabilities
CVE-2024-5599: FileOrganizer <= 1.0.7 - Sensitive Information Exposure via Directory Listing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-922
Description
The FileOrganizer – Manage WordPress and Website Files plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.7 via the 'fileorganizer_ajax_handler' function. This makes it possible for unauthenticated attackers to extract sensitive data including backups or other sensitive information if the files have been moved to the built-in Trash folder.
Affected products
- FileOrganizer: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: FileOrganizer 1.0.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fileorganizer/trunk/main/ajax.php#L85
- https://plugins.trac.wordpress.org/changeset/3098763/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/78e7b65d-91f8-477e-b992-3148c1b65d7b?source=cve
- https://plugins.trac.wordpress.org/browser/fileorganizer/trunk/main/ajax.php#L85
- https://plugins.trac.wordpress.org/changeset/3098763/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/78e7b65d-91f8-477e-b992-3148c1b65d7b?source=cve
Get alerted when CVE-2024-5599 or the next vulnerability affects your stack