What’s Vulnerable › Vulnerabilities
CVE-2024-5604: Bug Library < 2.1.2 - Admin+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Bug Library WordPress plugin before 2.1.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Bug Library: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Bug Library 2.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/29985150-8d49-4a3f-8411-5d7263b424d8/
- https://wpscan.com/vulnerability/29985150-8d49-4a3f-8411-5d7263b424d8/
Get alerted when CVE-2024-5604 or the next vulnerability affects your stack