What’s Vulnerable › Vulnerabilities
CVE-2024-56051: WordPress WPLMS plugin < 1.9.9.5 - Student+ Remote Code Execution (RCE) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in VibeThemes WPLMS wplms_plugin allows Code Injection.This issue affects WPLMS: from n/a through < 1.9.9.5.
Affected products
- VibeThemes Wordpress Learning Management System: before 1.9.9.5 — fixed in 1.9.9.5
How to fix
Upgrade to a fixed version: VibeThemes Wordpress Learning Management System 1.9.9.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56051 or the next vulnerability affects your stack