What’s Vulnerable › Vulnerabilities
CVE-2024-5606: Quiz And Survey Master < 9.0.2 - Contributor+ SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.0.2 is vulnerable does not validate and escape the question_id parameter in the qsm_bulk_delete_question_from_database AJAX action, leading to a SQL injection exploitable by Contributors and above role
Affected products
- ExpressTech Quiz And Survey Master: before 9.0.2 — fixed in 9.0.2
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e3eee6bc-1f69-4be1-b323-0c9b5fe7535e/
- https://wpscan.com/vulnerability/e3eee6bc-1f69-4be1-b323-0c9b5fe7535e/
Get alerted when CVE-2024-5606 or the next vulnerability affects your stack