What’s Vulnerable › Vulnerabilities
CVE-2024-5612: Essential Addons for Elementor – Best Elementor Templates, Widgets, Kits & WooCommerce Builders <= 5.8.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Lightbox and Modal Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Essential Addons for Elementor Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘eael_lightbox_open_btn_icon’ parameter within the Lightbox & Modal widget in all versions up to, and including, 5.8.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets: before 5.8.16 — fixed in 5.8.16
How to fix
Upgrade to a fixed version: wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets 5.8.16. Check the vendor advisory for mitigations.
References
- https://essential-addons.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8dbe4104-b7d1-484f-a843-a3d1fc02999d?source=cve
- https://essential-addons.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8dbe4104-b7d1-484f-a843-a3d1fc02999d?source=cve
Get alerted when CVE-2024-5612 or the next vulnerability affects your stack