What’s Vulnerable › Vulnerabilities
CVE-2024-56137: MaxKB RCE vulnerability in function library
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-78
Description
MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG). Prior to version 1.9.0, a remote command execution vulnerability exists in the module of function library. The vulnerability allow privileged users to execute OS command in custom scripts. The vulnerability has been fixed in v1.9.0.
Affected products
- 1Panel-dev MaxKB: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: 1Panel-dev MaxKB 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-76w2-2g72-cg85
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-76w2-2g72-cg85
Get alerted when CVE-2024-56137 or the next vulnerability affects your stack