What’s Vulnerable › Vulnerabilities
CVE-2024-56145: Craft CMS Code Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-06-02
- EPSS: 97.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-94
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
Affected products
- craftcms cms: from 3.0.0 before 3.9.14; from 4.0.0 before 4.13.2; from 5.0.0 before 5.5.2 — fixed in 3.9.14, 4.13.2, 5.5.2
How to fix
Upgrade to a fixed version: craftcms cms 3.9.14, 4.13.2, 5.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3
- https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9
- https://github.com/Chocapikk/CVE-2024-56145
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145
Get alerted when CVE-2024-56145 or the next vulnerability affects your stack