What’s Vulnerable › Vulnerabilities
CVE-2024-5615: Open Graph <= 1.11.2 - Unauthenticated Sensitive Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-200
Description
The Open Graph plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.11.2 via the 'opengraph_default_description' function. This makes it possible for unauthenticated attackers to extract sensitive data including partial content of password-protected blog posts.
Affected products
- willnorris Open Graph: before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: willnorris Open Graph 1.11.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/opengraph/trunk/opengraph.php#L369
- https://plugins.trac.wordpress.org/changeset/3097574/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f57dc0fe-07f3-457e-8080-fe530f6a9f01?source=cve
- https://plugins.trac.wordpress.org/browser/opengraph/trunk/opengraph.php#L369
- https://plugins.trac.wordpress.org/changeset/3097574/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f57dc0fe-07f3-457e-8080-fe530f6a9f01?source=cve
Get alerted when CVE-2024-5615 or the next vulnerability affects your stack