What’s Vulnerable › Vulnerabilities

CVE-2024-56171

Description

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a use-after-free in xmlSchemaIDCFillNodeTables and xmlSchemaBubbleIDCNodeTables in xmlschemas.c. To exploit this, a crafted XML document must be validated against an XML schema with certain identity constraints, or a crafted XML schema must be used.

Affected products

How to fix

Upgrade to a fixed version: xmlsoft libxml2 2.12.10, 2.13.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-56171 or the next vulnerability affects your stack