What’s Vulnerable › Vulnerabilities
CVE-2024-56180: Apache EventMesh: raft Hessian Deserialization Vulnerability allowing remote code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-14 · updated 2026-06-17
- Weakness: CWE-502
Description
CWE-502 Deserialization of Untrusted Data at the eventmesh-meta-raft plugin module in Apache EventMesh master branch without release version on windows\linux\mac os e.g. platforms allows attackers to send controlled message and remote code execute via hessian deserialization rpc protocol. Users can use the code under the master branch in project repo or version 1.11.0 to fix this issue.
Affected products
- Apache Software Foundation Apache EventMesh: from 1.10.1 before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache EventMesh 1.11.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/k9fw0t5r7t1vbx53gs8d1r8c54rhx0wd
- http://www.openwall.com/lists/oss-security/2025/02/14/7
Get alerted when CVE-2024-56180 or the next vulnerability affects your stack