What’s Vulnerable › Vulnerabilities
CVE-2024-56199: phpMyFAQ Vulnerable to Stored HTML Injection at FAQ
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, damage to the user experience, and potential abuse in phishing or defacement attacks. Version 4.0.2 contains a patch for the vulnerability.
Affected products
- thorsten phpMyFAQ: from 3.2.10 before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56199 or the next vulnerability affects your stack