What’s Vulnerable › Vulnerabilities
CVE-2024-56237: WordPress Contest Gallery plugin <= 24.0.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wasiliy Strecker / ContestGallery developer Contest Gallery contest-gallery allows Stored XSS.This issue affects Contest Gallery: from n/a through <= 24.0.3.
Affected products
- Contest Gallery Pro: before 24.0.4 — fixed in 24.0.4
How to fix
Upgrade to a fixed version: Contest Gallery Pro 24.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56237 or the next vulnerability affects your stack