What’s Vulnerable › Vulnerabilities
CVE-2024-56242: WordPress Arconix Shortcodes plugin <= 2.1.14 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tychesoftwares Arconix Shortcodes arconix-shortcodes allows Stored XSS.This issue affects Arconix Shortcodes: from n/a through <= 2.1.14.
Affected products
- tychesoftwares Arconix Shortcodes: before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: tychesoftwares Arconix Shortcodes 2.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56242 or the next vulnerability affects your stack