What’s Vulnerable › Vulnerabilities
CVE-2024-5626: Inline Related Posts < 3.7.0 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Inline Related Posts WordPress plugin before 3.7.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Inline Related Posts: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: Inline Related Posts 3.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6b03f450-4982-4f6c-a6f1-f7e85b1deec1/
- https://wpscan.com/vulnerability/6b03f450-4982-4f6c-a6f1-f7e85b1deec1/
Get alerted when CVE-2024-5626 or the next vulnerability affects your stack