What’s Vulnerable › Vulnerabilities
CVE-2024-56274: WordPress Astra Widgets plugin <= 1.2.15 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Astra Widgets astra-widgets allows Stored XSS.This issue affects Astra Widgets: from n/a through <= 1.2.15.
Affected products
- Brainstorm Force Astra Widgets: before 1.2.16 — fixed in 1.2.16
How to fix
Upgrade to a fixed version: Brainstorm Force Astra Widgets 1.2.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56274 or the next vulnerability affects your stack