What’s Vulnerable › Vulnerabilities
CVE-2024-5629: Out-of-bounds read in bson module of PyMongo
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read in the 'bson' module of PyMongo 4.6.2 or earlier allows deserialization of malformed BSON provided by a Server to raise an exception which may contain arbitrary application memory.
Affected products
- Debian Linux: 10.0
- MongoDB Inc PyMongo: before 4.6.3 — fixed in 4.6.3
How to fix
Upgrade to a fixed version: MongoDB Inc PyMongo 4.6.3. Check the vendor advisory for mitigations.
References
- https://jira.mongodb.org/browse/PYTHON-4305
- https://lists.debian.org/debian-lts-announce/2024/06/msg00007.html
- https://jira.mongodb.org/browse/PYTHON-4305
- https://lists.debian.org/debian-lts-announce/2024/06/msg00007.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00032.html
Get alerted when CVE-2024-5629 or the next vulnerability affects your stack