What’s Vulnerable › Vulnerabilities
CVE-2024-56320: GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-03 · updated 2026-06-17
- Weakness: CWE-285
Description
GoCD is a continuous deliver server. GoCD versions prior to 24.5.0 are vulnerable to admin privilege escalation due to improper authorization of access to the admin "Configuration XML" UI feature, and its associated API. A malicious insider/existing authenticated GoCD user with an existing GoCD user account could abuse this vulnerability to access information intended only for GoCD admins, or to escalate their privileges to that of a GoCD admin in a persistent manner. it is not possible for this vulnerability to be abused prior to authentication/login. The issue is fixed in GoCD 24.5.0. GoCD users who are not able to immediate upgrade can mitigate this issue by using a reverse proxy, WAF or similar to externally block access paths with a `/go/rails/` prefix. Blocking this route causes no loss of functionality. If it is not possible to upgrade or block the above route, consider reducing the GoCD user base to more trusted set of users, including temporarily disabling use of plugins such as the guest-login-plugin, which allow limited anonymous access as a regular user account.
Affected products
- gocd: before 24.5.0 — fixed in 24.5.0
How to fix
Upgrade to a fixed version: gocd 24.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/gocd/gocd/commit/68b598b97bd283a5a85e20d018d69fe86acf4165
- https://github.com/gocd/gocd/releases/tag/24.5.0
- https://github.com/gocd/gocd/security/advisories/GHSA-346h-q594-rj8j
- https://www.gocd.org/releases/#24-5-0
Get alerted when CVE-2024-56320 or the next vulnerability affects your stack