What’s Vulnerable › Vulnerabilities
CVE-2024-56323: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-13 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is an authorization/permission engine. IN OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2) are vulnerable to authorization bypass under the following conditions: 1. calling Check API or ListObjects with a model that uses [conditions](https://openfga.dev/docs/modeling/conditions), and 2. calling Check API or ListObjects API with [contextual tuples](https://openfga.dev/docs/concepts#what-are-contextual-tuples) that include conditions and 3. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`). Users are advised to upgrade to v1.8.3. There are no known workarounds for this vulnerability.
Affected products
- openfga Helm Charts: from 0.1.38 before 0.2.19 — fixed in 0.2.19
- openfga: from 1.3.8 before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.19; openfga 1.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56323 or the next vulnerability affects your stack