What’s Vulnerable › Vulnerabilities
CVE-2024-56328: HTMLi(XSS without CSP) via Onebox urls in Discourse
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source platform for community discussion. An attacker can execute arbitrary JavaScript on users' browsers by posting a maliciously crafted onebox url. This issue only affects sites with CSP disabled. This problem has been patched in the latest version of Discourse. Users are advised to upgrade. Users unable to upgrade should enable CSP, disable inline Oneboxes globally, or allow specific domains for Oneboxing.
Affected products
- discourse: before 3.3.3; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3 — fixed in 3.3.3, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.3, 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-56328 or the next vulnerability affects your stack